IPv6 Cisco Switch

Aus xinux.net
Zur Navigation springen Zur Suche springen

Weiter geht es

  • Wir bauen einen Layer3 Switch ein
  • Dieser kommt an unser Transit Netz
  • Wir Nutzen hier das VLAN 4
  • IP 2a02:24d8:71:2444::2
  • Wir stellen die Default Route auf 2a02:24d8:71:2444::1
  • Wr testen

Schaubild

Einrichtung

Hostname

  • configure terminal
  • hostname cisco-switch
  • end

Vlans

  • configure terminal
  • vlan 4
  • name transit
  • vlan 5
  • name lan
  • exit
  • end

Zurordnung zum Interface

Gi0/0

  • configure terminal
  • interface GigabitEthernet0/0
  • description to-router
  • switchport mode access
  • switchport access vlan 4
  • exit
  • end

Gi0/1-3

  • configure terminal
  • interface range GigabitEthernet0/1-3
  • description to-lan
  • switchport mode access
  • switchport access vlan 5
  • exit
  • end

Ipv6 Adresse zum Vlan 4

  • configure terminal
  • interface Vlan4
  • ip address 192.168.44.2 255.255.255.0
  • ipv6 address 2A02:24D8:71:2444::2/64
  • ipv6 nd prefix default no-advertise
  • ipv6 nd ra suppress all
  • no shutdown
  • exit
  • end

Ipv6 Adresse zum Vlan 5

  • configure terminal
  • interface Vlan5
  • ip address 192.168.45.2 255.255.255.0
  • ipv6 address 2A02:24D8:71:2445::2/64
  • ipv6 nd prefix default no-advertise
  • ipv6 nd ra suppress all
  • no shutdown
  • exit
  • end

Test

  • ping ipv6 2a02:24d8:71:2444::1
Sending 5, 100-byte ICMP Echos to 2A02:24D8:71:2444::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/5 ms

Default Route

  • configure terminal
  • ipv6 route ::/0 2a02:24d8:71:2444::1
  • ip route 0.0.0.0 0.0.0.0 192.168.44.1
  • end

Testen der Defaultroute

  • ping ipv6 2001:4860:4860::8888
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:4860:4860::8888, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/7 ms

IPv6 Nameserver

  • configure terminal
  • ip name-server 2001:4860:4860::8888
  • ip name-server 8.8.8.8
  • end

Nameserver Test

  • ping ipv6 google.de
Translating "google.de"...domain server (2A01:4F8:C17:2CC5::1) [OK]
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2A00:1450:4001:827::2003, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/6 ms

Forwarding von IPv6 Traffic

  • configure terminal
  • ipv6 unicast-routing
  • ip routing
  • end